opkg install kmod-usb-uhci kmod-usb-storage block-mount block-hotplug kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
tar -C /overlay -cvf - . | tar -C /mnt/sda1 -xf - The following is an example for an extroot fstab mount entry for pivot overlay. Note the fstype, options and enable_fchk options are optional, see fstab.
config mount
option target /overlay option device /dev/sda1 option fstype vfat option options rw,sync option enabled 1 option enabled_fsck 0
http://wiki.hidemyass.com/OpenWRT_OpenVPN_Setup
root@OpenWrt:/etc/config# cat network
config interface 'loopback'
option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0' option type 'bridge' option proto 'static' option ipaddr '192.168.0.254' option netmask '255.255.255.0' option gateway '192.168.0.1' list dns '192.168.0.1' list dns '8.8.8.8'
root@OpenWrt:/etc/config# cat wireless config wifi-device radio0
option type mac80211 option channel 11 option macaddr 14:cf:92:a0:fb:d6 option hwmode 11ng option htmode HT20 list ht_capab SHORT-GI-20 list ht_capab SHORT-GI-40 list ht_capab RX-STBC1 list ht_capab DSSS_CCK-40 # REMOVE THIS LINE TO ENABLE WIFI: option disabled 0
config wifi-iface
option device radio0 option network lan option mode ap option ssid OpenWrt option encryption none
#!/bin/sh packages=“kmod-fs-ext4 kmod-usb-storage block-mount” dev=sda2 swapdev=sda1 fstype=ext4 options=rw,sync,noatime
enable() { echo “Stopping automounting” /etc/init.d/fstab stop
opkg update opkg install $packages
sleep 10
while [ ! -b /dev/$dev ] ; do echo “/dev/$dev not found please insert the USB storage device” read junk done
mkdir -p /mnt/$dev mount /dev/$dev /mnt/$dev -t $fstype -o $options
tar -C /overlay -cvf - . | tar -C /mnt/$dev -xf -
uci add fstab mount uci set fstab.@mount[-1].device=/dev/sda2 uci set fstab.@mount[-1].options=$options uci set fstab.@mount[-1].enabled_fsck=0 uci set fstab.@mount[-1].enabled=1 uci set fstab.@mount[-1].target=/overlay uci set fstab.@mount[-1].fstype=$fstype
uci add fstab swap uci set fstab.@swap[-1].device=/dev/sda1 uci set fstab.@swap[-1].enabled=1
uci commit fstab
/etc/init.d/fstab enable
echo “Overlay enabled, you need to reboot to activate it” }
enable
openwrt pptp http://bluemarmot.ekibox.net/en/node/71